USB Cable not connecting

Anything and everything CNC-Shark-related

Moderators: ddw, sbk, al wolford

USB Cable not connecting

Postby jazpeitia » Tue Mar 10, 2015 12:07 pm

Hello everyone, I've been having issues with my USB cable connecting from the controller box to the computer. It says usb not recognized, maybe a quarter of the time it works if I keep unplugging and plugging back in but eventually it will lose connection as the cnc is cutting. I have tried numerous usb cables with the same results. I have a Shark CNC black diamond. Thanks for any help on this issue.

Joel
jazpeitia
 
Posts: 46
Joined: Wed Dec 04, 2013 8:59 am

Re: USB Cable not connecting

Postby 4DThinker » Tue Mar 10, 2015 1:07 pm

All I can recommend is to open up the controller box (unplugged) and inspect the USB port for a loose/shorting connection. This assumes you've tried more than one cable, and more than one USB port on your PC.

If the port is failing, possibly with bad solder job or such, and you can't fix it yourself then a call to NextWave support is next. You'll probably have to send it to them for repair.
4DThinker
 
Posts: 949
Joined: Wed Jun 27, 2012 9:00 am

Re: USB Cable not connecting

Postby jazpeitia » Tue Mar 10, 2015 1:17 pm

Thanks 4D, I will check that out. I manage to get it connected for a little this morning enough to send the GCODE to the box and bam...... the controller blew my last fuse.... my luck. but thanks again!!
jazpeitia
 
Posts: 46
Joined: Wed Dec 04, 2013 8:59 am

Re: USB Cable not connecting

Postby jeb2cav » Tue Mar 10, 2015 2:20 pm

Hi Joel,

The other thing you should check based on your description is the power settings on the computer you are using. Make sure your usb ports are set to always on. If they are, and you're still getting this intermittent disconnect, and as 4D assumes you've tried other cables and other ports, you may want to touch base with NWA support - and perhaps arrange to send your control box in for warranty maintenance.
jeb2cav
Site Admin
 
Posts: 1512
Joined: Thu Sep 30, 2010 7:04 pm
Location: Kentucky

Re: USB Cable not connecting

Postby Eagle55 » Sat Mar 14, 2015 9:11 pm

Here is something else to consider. I just upgraded my computer to a touch screen (and LARGE one at that) and love it. However, the first night that I connected it the USB port was fine, but the next night it began losing connection to the controller. It would "ding" when I connected but then say it wasn't connected and when I unplugged it, it would make the sound like when you disconnect a USB connected device. I was wringing my hands when it kept doing it even after it power cycled. Granted the computer was a reconditioned unit and might have issues with one particular port. I plugged it into one of the other many USB ports and haven't had a problem since. Still don't know if there was something wrong with that port or if it was an issue with power to it or what, but something you might want to try just as a way of gather data to compare.

Roger
CNC Shark HD ~ Control Panel 2.0 ~ Windows 7 & XP
Located in West Tennessee near the Tennessee River
http://www.eaglecarver4.com
Eagle55
 
Posts: 777
Joined: Sun Nov 20, 2011 8:44 pm

Re: USB Cable not connecting

Postby deputydust » Fri Jul 10, 2015 5:54 pm

Newbie and First time poster. I ran into the same issue today. I installed Shark CP 1.6 on a tablet (mini laptop) last night and the problems started. The USB would connect then quickly disconnect. Tried my regular laptop and I had the same problem. Windows 8.1 (both devices) said there was a problem with the USB device and disconnected it. I reloaded the 1.6 CP on my regular laptop and it worked, did the same thing for the tablet and it worked also. All I can figure is when loading the CP 1.6 for the first time on the tablet it messed up the USB drivers in the Controller which is why it affected both devices. Hope this helps for anyone else that runs into this problem.

Dave
deputydust
 
Posts: 2
Joined: Wed Jun 24, 2015 12:08 am

Re: USB Cable not connecting

Postby NewAgent45 » Sun Jul 12, 2015 9:14 am

I have had a related issue with initial USB connection with the Shark controller since I replaced the computer that runs my machine. The connection issue only occurs on initial start-up and once connected we have never seen the issue when running the machine. We are using a Dell XPS Laptop with a docking port. We connect all the peripherals (External Monitor, USB Speakers, Blue Tooth Mouse & Keyboard and the Shark controller). We also use the wired network connection on the dock for the network connection. EPS laptops don’t have a wired network connection. We have upgraded the controller software and still see the issue. The OS is Win 8.1 that is fully updated.

I usually work around this issue by selecting abort on startup so the controller interface loads. Then I shut off the controller for a few minutes and then cycle it back on. I should note I hear the audible sound signaling USB port disconnect and re-connect when cycling controller power. Sometimes I have to repeat this sequence several time till I see the controller is connected when the jog mode is displayed. The controls will be grayed out when there is no connection.

I see Joe suggests reviewing the USB ports settings. (i.e., set to always on) We plan to check those settings. Thanks Joe!
I see that Roger mentioned use of a Touchscreen monitor. This is interesting as my XPS has a built in touchscreen and I’m using the build-in monitor as well as the external wall mounted monitor.

Rodger also mentioned switching the controller to a different USB port. This is something I can easily try.
This issue is just a nuisance for me as I have never experienced a disconnection after initially establishing controller connection.

Have a great Day!
Rod
User avatar
NewAgent45
 
Posts: 221
Joined: Sun Sep 08, 2013 8:29 am
Location: Florida, USA

Re: USB Cable not connecting

Postby csclaser » Mon Aug 10, 2015 2:23 pm

I had this issue with a new laptop (win 8.1). Sent the laptop in with controller to NWA. NWA told me that they do not support anything above windows 7. I gave the new laptop to my son and bought a window 7 computer (Dell Inspiron desktop) and the issue went away until my most recent window update. Now it is back again. I think that until NWA issues a patch these problems will continue to become more common.
csclaser
 
Posts: 9
Joined: Tue Mar 06, 2012 10:21 pm

Re: USB Cable not connecting

Postby Christyk35 » Tue Mar 15, 2016 5:58 pm

Very frustrating, usb says not connected. I have to unplug it, and plug it back in several times before it will connect. I thought it was my old laptop that I was using. Just got a new laptop this week and guess what, yep, doing the same thing since day one. Pretty sure my warranty is up as I have had my machine for a year and a half.
Christyk35
 
Posts: 9
Joined: Mon Oct 20, 2014 4:26 pm

Re: USB Cable not connecting

Postby Tpellicci » Sat Aug 18, 2018 6:29 pm

Along with the rest of you, I also have had the same issue. I don't think its the cable and I also don't think its the ports as there are too many of use with the same issue. The issue I would believe is this OEMTECH (winUSB) ncPodWinUsb (11/3/2012 . It was written in 2012 and works on machines with Vista without an issue and. I also know on xp it didn't have the correct drivers for the usb ports they were missing an INF file which created some .dll files. So the isuue is the outdated OEMTECH file. I asked Nex Wave and they said just use the shark touch screen. I think thats a pain with little help from the Owners manual. So unless OEMTECH updates their driver this isn't going to go away and the touch screen is going to be the only way..
Tpellicci
 
Posts: 1
Joined: Sat Aug 04, 2018 3:59 pm

Next

Return to CNC Shark

Who is online

Users browsing this forum: No registered users and 4 guests