Help needed.....Stops in the middle of the program?

Anything and everything CNC-Shark-related

Moderators: ddw, sbk, al wolford

Re: Help needed.....Stops in the middle of the program?

Postby jeb2cav » Sat Apr 23, 2011 7:04 pm

Hi Jerry,

Buc was able to duplicate the failure using your tap file. He then deleted the toolpath from your project, and created a new toolpath, then saved that tap file and ran it to completion/successfully.

I deleted the toolpath in your project, created a new one, and ran the new tap file to completion/successfully.

Both of our tap files are a little more than 1/2 the size on disk when compared to the one you posted. The only thing I noticed is that after I deleted the original toolpath, and added a new one, it stated a .125" EM had been selected. But, when I hit edit, the tool was a generic Imperial tool, and not the specific .125 EM in my tool database. I then selected the tool from the tool database and generated the toolpath.

The tap file I generated is a few lines longer than Buc's. I assume it is a result of minor differences in how I configured this particular cutter when compared to Buc's tool library. It also ran to completion/success.

When you setup this project, did you generate individual toolpaths for each gear or each type of gear? Or, did you select all of them and generate a single toolpath? Purely speculation, but it may be that this particular toolpath got into an odd state - and from the toolpath dialogue it looks like you have a valid tool selected, but only when you select edit do you have the opportunity to see that some generic thing is in play - and this generic thing has no parameters. The result it the failure you are seeing.

Can you try deleting the toolpath in this simple project, creating a new toolpath, edit the tool to ensure you have a tool in your tool library selected, and see if that works? I've also attached Buc's tap file for what it's worth.
Profile 1bucgearEM.tap.crv
Delete the .crv - this is a tap file
(16.23 KiB) Downloaded 84 times
Site Admin
Posts: 1514
Joined: Thu Sep 30, 2010 7:04 pm
Location: Kentucky

Re: Help needed.....Stops in the middle of the program?

Postby JerryBurks » Sat Apr 23, 2011 7:30 pm

Hey, thanks so much guys for taking the time analyzing my odd problem. In the meantime I have written to NextWave support. At least they should know about this quirk.

Today was lathe time (all by hand, no computer whatsoever :roll: ) and the Shark got a break. I will try your recommendations over the next couple of days.

Wait, I lied....there is a microcontroller in the motor drive of the lathe and sure enough it stalls when I choose max speed :lol:
Posts: 92
Joined: Mon Mar 28, 2011 12:07 am

Re: Help needed.....Stops in the middle of the program?

Postby JerryBurks » Sun May 01, 2011 10:14 pm

Just an update about my looks like the "stop bug" happens under certain conditions when there is a ramp from one pass to the next. My profile path actually has some really tiny arcs because the dedendum of the gears to cut is only a few 1/1000 larger than the bit diameter and maybe the control box firmware can not handle such small numbers. Well, just a guess. I have not heard back from Tim at NextWave on my email but I just started cutting the identical gears without the ramp function and everything works just fine. The ramps or spiral transitions are anyway annoying because they slow the feed rate way down for some reason.

With some continued experimentation I found so far the parameters for best accuracy of my plywood gears are 0.05" pass depth, 30"/min feed conventional direction and -0.004" allowance offset (over=cut) using an 1/8" up-cut end mill. I would like to go faster or deeper but then I see the gear teeth becoming deformed due to the flexing of the gantry and z-axis under load. I suspect that is just the limit of what can be done with a Shark.

I would be interested what parameters and settings other owners have used when cutting matching precision parts, e.g. for clocks. I am trying to achieve profile accuracy better than 0.005"

Posts: 92
Joined: Mon Mar 28, 2011 12:07 am

Re: Help needed.....Stops in the middle of the program?

Postby rpitz » Sun Oct 29, 2017 7:05 pm

Hi Jerry,
I had the same problem with my machine (Shark Pro Plus, using ASPIRE 9.01) stopping shortly after starting to cut a tool path. It always stopped at the exact same point. The router shutoff and the tool just stayed at its last position ( tool did not raise up or move to home position). I tried running the tool path several times with exact same results. I was cutting some simple lettering using a font called “Toy Train” that were converted to curves. I tried turning off the control box and rebooting the computer but again the same results. I could see nothing unusual in the G code at the point where the machine stopped (not an expert in G code however). So then I moved the starting point of the vectors to a different point and made the machine start cutting at a different location and then the machine completely cut the tool path without stopping.
Posts: 1
Joined: Tue May 31, 2011 1:53 pm


Return to CNC Shark

Who is online

Users browsing this forum: No registered users and 2 guests