Nextwave 4th Axis Inaccurate?

Everything 4th Axis

Moderators: sbk, al wolford

Nextwave 4th Axis Inaccurate?

Postby wallace9958 » Wed Apr 03, 2019 8:51 pm

I purchased the 4th axis recently and am using it to make picture frame stiles with one slight hiccup. Essentially, what I am doing is:

Tool path 1 -> Dimension the job with a surface planing bit.
Surface plane the top.
Rotate to 90 and surface plane the right side.
Cut out a rabbet for a cloth inner frame.
Rotate to 180 and surface plane the bottom.
Rotate to 270 and surface plane the left side.
Rotate back to zero.

Tool path 2 -> 3D Roughing
Tool path 3 -> 3D Finishing

Sadly, I have to run this in three files since I haven't upgraded to an ATC Spindle yet. To create tool path 1, I am simply outputting five different pocket tool paths to a single tool path since they use the same tool. Then, I am manually editing the gcode to insert the 4th(A) Axis rotation. This is simple and quick to do using VCarve Desktop. Measuring with calipers, my finished parts are within about 0.003" along the length which I can happily live with. All in all, this worked great and yielded a successful first run.

What vexes me is that the position of the 4th(A) Axis is never quite spot on, at least according to the Shark controller. It's frequently off by 0.1 degrees even at common angles like 0, 90, 180, 270. Worse, returning is often off by 0.1 degrees. Often, I'll do something like:
Move from 0 -> 90 -> 0 and see actual results more like:
0 -> 89.9 -> 0.1

Generally speaking, my research into stepper motors indicates that they tend to rotate in 1.8 degree increments. Obviously, we're using micro stepping to get sub degree movements and so I am rather confused as to why I can't hit the 0, 90, etc., numbers spot on. They ought to be perfectly divisible with or without micro-stepping; at least if we assume a 1.8 degree rotation per step.
e.g., 360(full revolution) / 1.8(step increment) = 200
or: 360(full revolution) / 1.8(step increment) * 64(micro-steps) = 12,800

Has anyone else seem this kind of behavior? Any way to resolve it or at least explain it? I appreciate any help or information. Thanks!

Alex
wallace9958
 
Posts: 2
Joined: Tue Mar 26, 2019 1:53 pm

Return to Everything 4th Axis

Who is online

Users browsing this forum: No registered users and 0 guests