Not starting where I think it should

Discussion/questions about software used with your CNC Shark and programming issues

Moderators: sbk, al wolford

Post Reply
OCEdesigns
Posts: 98
Joined: Fri Jan 11, 2019 8:26 am

Not starting where I think it should

Post by OCEdesigns »

This is my first program and I watched several tutorials but I'm still lost. I have set the X,Y zeros and used the touch plate for Z zero on my work piece. I load the program and when I hit start the spindle moves about 2 inches away off the working piece on the X axis and then starts the plunge. I just stop it at that point. What am I doing wrong?? Or what am I missing in my program?

When I am setting my X, Y, Z zeros on the wood piece with the pendant, am I actually telling the CNC where home is and not the edge of my work piece? That is all I can think of.
Shark HD4 Extended Bed, Water Cooled Spindle. VCarve Pro 9.5

User avatar
Kayvon
Posts: 426
Joined: Tue Oct 21, 2014 11:46 pm

Re: Not starting where I think it should

Post by Kayvon »

When you zero out X, Y, and Z, you're telling the CNC where zero (or "origin") is. Your design will dictate where everything else is in relation to that.

Check your design file to see if origin is at the top or bottom of your workpiece. If you're using a touchplate to zero off against your spoilboard, you want the origin to be at the base (not the top) of your workpiece so the positions are consistent.

OCEdesigns
Posts: 98
Joined: Fri Jan 11, 2019 8:26 am

Re: Not starting where I think it should

Post by OCEdesigns »

Kayvon wrote:When you zero out X, Y, and Z, you're telling the CNC where zero (or "origin") is. Your design will dictate where everything else is in relation to that.

Check your design file to see if origin is at the top or bottom of your workpiece. If you're using a touchplate to zero off against your spoilboard, you want the origin to be at the base (not the top) of your workpiece so the positions are consistent.

I have zeroed X, Y, and Z several times and it still does this. The design files shows I am taking my Z origin from the top of the work piece. I use the touch plate on the top of the work piece. I have tried about 8 different things and zero the machine X, Y, to the corner of the work piece then Zero Z with Touch plate. I hit Run and the X axis moves away from the piece by about 2 inches every time!
Shark HD4 Extended Bed, Water Cooled Spindle. VCarve Pro 9.5

User avatar
Kayvon
Posts: 426
Joined: Tue Oct 21, 2014 11:46 pm

Re: Not starting where I think it should

Post by Kayvon »

Can you try again with something painfully simple? Have it draw a small square and see how it reacts. From there, we can see if the gcode matches the actions and figure out what to do next.

OCEdesigns
Posts: 98
Joined: Fri Jan 11, 2019 8:26 am

Re: Not starting where I think it should

Post by OCEdesigns »

Kayvon wrote:Can you try again with something painfully simple? Have it draw a small square and see how it reacts. From there, we can see if the gcode matches the actions and figure out what to do next.
Thanks for the reply. I guess I should have deleted this post. I posted in another area and was able to figure it out. I was setting up my program with the starting datum point in one corner but setting the X, Y zero on my work piece in a different corner. I was misinterpreting the position! Once I got that figured out it has been good!.
Shark HD4 Extended Bed, Water Cooled Spindle. VCarve Pro 9.5

Post Reply